Bethnet - Clarens Castello Tower Down – Incident details

All systems operational

Clarens Castello Tower Down

Resolved
Partial outage 50 %
Started 5 days agoLasted about 15 hours

Affected

Clarens

Partial outage from 4:00 PM to 7:08 AM

Clarens Wireless

Partial outage from 4:00 PM to 7:08 AM

Updates
  • Resolved
    Resolved

    Invertor Repaired Castello Tower is back online.

  • Identified
    Identified

    We have identified that the main invertor is damaged. Our Technicians are busy with the repairs.