Bethnet - Wireless Towers down – Incident details

Eureka FTTH experiencing partial outage

Wireless Towers down

Resolved
Major outage
Started 15 days agoLasted 1 day

Affected

Bethlehem Wireless

Major outage from 8:00 AM to 8:04 AM, Operational from 8:04 AM to 8:38 AM, Partial outage from 8:38 AM to 2:32 PM, Operational from 2:32 PM to 3:33 PM

Updates
  • Resolved
    Resolved

    All Towers Back online.

  • Update
    Update

    Replaced Hardware for Vogelfontein. All Online
    Monitoring.

  • Update
    Update

    MAC , Watertower and Eureka Church Towers back online.
    Vogelfontein still offline, we are busy with replacement equipment for Vogelfontein tower.

  • Update
    Update

    We implemented a Temporary Fix to get the towers online while Eskom is working on the blown transformer.
    We are monitoring the situation to make sure that everything stays online.

  • Monitoring
    Monitoring

    Latest update we have from Eskom is that they will be able to replace the power cables for MAC tower by tomorrow, Monday 20 October 2025.

    For the Vogelfontein tower we will only be able to replace equipment that was damaged by lightning by tomorrow.

  • Update
    Update

    Problem on Mac Tower is Electricity. Fault has been Reported to Eskom. We are waiting on them to restore power to the tower.
    Watertower and Eureka Church tower also affected.
    Vogelfontein Tower also down. We can only Repair this on monday.

  • Identified
    Identified
    We are continuing to work on a fix for this incident.