Bethnet - Bethnet Mac tower Down – Incident details
Report an issue
Get updates
Email
Report an issue
Get updates
Dark mode
All systems operational
Bethnet Mac tower Down
Resolved
Partial outage
30 %
Started 6 days ago
Lasted 13 minutes
Affected
Bethlehem Wireless
Partial outage from 12:45 PM to 12:57 PM
Updates
Resolved
June 30, 2025 at 12:57 PM
Resolved
June 30, 2025 at 12:57 PM
This incident has been resolved.
Investigating
June 30, 2025 at 12:45 PM
Investigating
June 30, 2025 at 12:45 PM
We are currently investigating this incident.