Bethnet - Bethnet Mac tower Down – Incident details

All systems operational

Bethnet Mac tower Down

Resolved
Partial outage
Started 28 days agoLasted about 11 hours

Affected

Bethlehem Wireless

Operational from 11:30 PM to 10:01 AM

Updates
  • Resolved
    Resolved

    Power has been restored.
    All is back online.

  • Identified
    Identified

    Mac Tower Affected by weather. Watertower and Church tower is also Affected.
    Power is down and we are waiting for Eskom to Fix the Power.