Bethnet - Fibre Cable break – Incident details

All systems operational

Fibre Cable break

Resolved
Major outage
Started 11 days agoLasted about 14 hours

Affected

Bethlehem FTTH

Major outage from 12:08 AM to 1:52 PM

Panorama FTTH

Major outage from 12:08 AM to 1:52 PM

Bethlehem Wireless

Partial outage from 12:08 AM to 1:52 PM

Updates
  • Resolved
    Resolved

    Damage has been repaired. Thank you for the understanding.

    If your service is still affected,please reboot all hardware. If the problem persists,please do not hesitate to contact our support team on 0826372424.

  • Investigating
    Investigating

    Cable has been damaged by third party on the corner of Sonop and Baartman street. Fibre team will commence repairs early morning on Saturday, 22 March 2025.

    The backbone cable has been damaged,causing an outage on our fibre network in Panorama as well as our Birdcage,Nthute,Bethlehem Comprehensive and Lions Rock wireless towers.

    Connectivity will be restored as soon as the damage has been repaired.