Bethnet - Cable Break - Bethlehem Industrial Area – Incident details

All systems operational

Cable Break - Bethlehem Industrial Area

Resolved
Partial outage
Started 20 days agoLasted about 1 hour

Affected

Bethlehem FTTH

Partial outage from 6:11 AM to 7:17 AM

Industrial Area

Partial outage from 6:11 AM to 7:17 AM

Updates
  • Resolved
    Resolved

    The cable break has been repaired. All clients are back online.

  • Identified
    Identified

    We have identified where the cable break is in Bethlehem Industrial Area. Repairs are being made.