Bethnet - Cable Break in CBD area – Incident details

All systems operational

Cable Break in CBD area

Resolved
Major outage
Started 12 days agoLasted about 9 hours

Affected

Bethlehem FTTH

Partial outage from 6:30 AM to 8:55 AM, Major outage from 8:55 AM to 3:18 PM

CBD FTTH

Partial outage from 6:30 AM to 8:55 AM, Major outage from 8:55 AM to 3:18 PM

Updates
  • Resolved
    Resolved

    Repairs have been completed and all affected clients are back online.

    Thank you for your patience and understanding while our team worked to restore full connectivity. If you are still experiencing any issues, please let us know so we can assist immediately.

    On our Support line - 082 637 2424

  • Monitoring
    Monitoring

    In order to complete the necessary repairs to the damaged infrastructure, additional cable sections need to be replaced. As a result, more clients in the CBD area will be temporarily affected and may experience connectivity interruptions.

    We sincerely apologise for the inconvenience caused. These measures are essential to ensure a stable and reliable network once repairs are finalised.

    Our technical team remains on site and is working diligently to restore full service as quickly and efficiently as possible. We appreciate your patience and understanding.

  • Identified
    Identified

    We have identified that our main Backbone cable and Service cable has been cut. Clients in the area of Louw and Naude Street , CBD will be affected. Sorry for the inconvenience. We will work to get it back online as soon as possible.

  • Investigating
    Investigating

    We are currently investigating where the cable break happened. Our technicians are on the way to find and repair the broken cable.