Bethnet - Power Outage at Eureka Church – Incident details

All systems operational

Power Outage at Eureka Church

Resolved
Partial outage 30 %
Started about 1 month agoLasted 19 minutes

Affected

Bethlehem Wireless

Partial outage from 7:07 AM to 7:26 AM

Updates
  • Resolved
    Resolved

    Power has been restored at Eureka Church. All sectors are back online.

  • Identified
    Identified

    Please note that the Eureka Church is currently experiencing a power failure due to the heavy weather. Electricians are busy making repairs. Currenlty we have no ETA on repairs.